Cannot run Perl script at set times

nnCron and nnCron LITE discussion

Cannot run Perl script at set times

Postby DrPL » Thu, 11 Feb 2010, 18:48

I've been given the task of evaluating nnCron LITE and like what I see. I do have a question about it though, which other people have asked.
I'm trying to set up a perl script to run at set intervals. My file was
*/15 * * * * * C:\wamp\www\
but that didn't work - the DOS window flashes up, I get "Start result: 0" in the log file and nothing happens.

I've tried including the path to the Perl interpreter in the table, like this:
*/15 * * * * * C:\Perl\bin\perl.exe C:\wamp\www\
with the same result (even encasing the two paths in quotes)

Even putting the above commands in a batch file and running it as follows:
*/5 * * * * * C:\wamp\www\count.bat
doesn't work.

What am I doing wrong?

Best wishes

Posts: 1
Joined: Thu, 11 Feb 2010, 18:31

Re: Cannot run Perl script at set times

Postby 1eyedB&IT » Fri, 14 Jan 2011, 23:25

I am having the same issue. I have tried installing nncron lite to the C:\cron directory and have tried running the script directly, with an explicit path to perl.exe, and with a bat file. Nothing seems to work. I made sure that nncron lite would run a simple .bat file with good results. I am on Windows 7 and did not have any trouble running it on Windows XP. I suspect it might be a security issue with Windows 7 but made sure the script properties allowed both System and user to run it.
Some help would be appreciated as this is the only roadblock I have before moving to Windows 7.
Posts: 3
Joined: Thu, 06 Jan 2011, 22:46

Return to nnCron forum (English)

Who is online

Users browsing this forum: No registered users and 2 guests