nnCron portable, problem

nnCron and nnCron LITE discussion

nnCron portable, problem

Postby majkinetor » Wed, 24 May 2006, 10:47

Hi there.

I am trying to create portable installation for latest version of nnCron.
That is, I need once installed version of nnCron to be functional on other system's as well, or after system reinstallation.

I detected that only peace of information nnCron keeps in Registry is path where it is installed (not counting service information). Service can be installed using supplied batch scripts.

What is strange is that application doesn't work on other systems, it crash on starting service, although I provided the same registry information from original machine. I monitored everything with RegMon and FileMon (from SysInternals) and with few other utilities but any of them fail to detect any more integration to the system then those I mention.

Can anybody tell, me, possible the author, what should I do to make it installed once and forever. If not, can we expect non-service version, or switch, or something, that will not depend on current system, but will keep all information within its directory.

Thank you.
Posts: 2
Joined: Sun, 21 May 2006, 19:30

Postby Valery_Kondakoff » Wed, 24 May 2006, 11:02

I'm pretty sure it crashes just because you haven't run the install_svc.bat before starting the service.

You shouldn't enter the registry info when moving nnCron to another system - it will be entered automatically. All the nnCron settings are saved to nncron.ini file.

If you like to start nnCron as an ordinary application (not as a system service), just start nncron.exe with -ns command line switch (see docs for more details).
User avatar
Site Admin
Posts: 769
Joined: Thu, 01 Jul 2004, 20:49
Location: Moscow, Russia

Postby majkinetor » Thu, 25 May 2006, 15:03

So it is a bug then.

What I did:

1. Installed application to c:\nnCron
2. Copy data to another place, d:\Utils\nnCron
2. Uninstall application
3. Start the app -> crash
4. Run install_svc.bat ->crash
5. Run net start ... ->crash
6. Run tray.exe.. it shows up in the tray, with tooltip "[-1]". Left or right click didn't work. Double click exit the tray app.

I thought something is wrong with my system, so I tried on 4 different systems. It crashed on all of them !

And I didn't enter service information into registry, as you already have batch for that. I just put the path to the nnCron folder, nothing more, since nothing more is originally added except sevice information. I know that this isn't important since I can delete it from my registry and nnCron will still work.

What is funny is that today I started again to show you what exactly steps I made... but now it works !? Don't know how, I switched to several other systems and it again worked OK. Don't know ... I feel stupid now... but 4 different system's can't lie. Hm..... maybe some virus.... thinking loud.

Anyway, thanks for the -ns info, you should add that also as a batch script for us who don't like to read manuals :)

Thanks for the great app. I was serchng something like this for a long time. Its good to know that somebody care for system resources ( I noticed you created separate exes for everything, so it is loaded only what is needed)

Keep up the good work. I can inform you about the problem if it rises again (send you a video or something....)
Posts: 2
Joined: Sun, 21 May 2006, 19:30

Return to nnCron forum (English)

Who is online

Users browsing this forum: No registered users and 0 guests